Как написать программу «Угадай число» на Python

Введение в игру «Угадай число»

Игра «Угадай число» — это классическая игра, которая помогает развивать логическое мышление и навыки программирования. В этой статье мы рассмотрим, как написать простую версию этой игры на языке Python. Мы создадим программу, которая будет генерировать случайное число, а игроку нужно будет его угадать.

Что нам понадобится

Для начала убедитесь, что у вас установлен Python. Если вы еще не установили его, вы можете скачать последнюю версию с официального сайта python.org.

Также вам понадобится текстовый редактор или IDE (например, PyCharm, VSCode или даже стандартный блокнот), чтобы писать код.

Основные шаги создания игры

Создание игры «Угадай число» можно разбить на несколько простых шагов:

  1. Генерация случайного числа.
  2. Запрос ввода от пользователя.
  3. Сравнение введенного числа с загаданным.
  4. Вывод подсказок и завершение игры.

Генерация случайного числа

Первым делом нам нужно импортировать модуль random, который позволит нам генерировать случайные числа. Мы будем загадывать число в диапазоне от 1 до 100.

import random

secret_number = random.randint(1, 100)

Здесь мы используем функцию randint, чтобы получить случайное число в указанном диапазоне.

Запрос ввода от пользователя

Теперь мы можем запросить у пользователя ввод. Для этого используем функцию input. Важно помнить, что ввод от пользователя всегда будет строкой, поэтому нам нужно преобразовать его в целое число.

user_guess = int(input("Угадайте число от 1 до 100: "))

Сравнение введенного числа с загаданным

Теперь, когда у нас есть загаданное число и число, введенное пользователем, мы можем сравнить их. Если пользователь угадал число, мы поздравим его. Если нет, то дадим подсказку, больше или меньше загаданное число.

if user_guess < secret_number:
    print("Слишком низко!")
elif user_guess > secret_number:
    print("Слишком высоко!")
else:
    print("Поздравляем! Вы угадали число!")

Цикл игры

Чтобы игра продолжалась до тех пор, пока пользователь не угадает число, мы можем использовать цикл while. Это позволит нам повторять запрос ввода и сравнение до тех пор, пока игрок не угадает число.

while True:
    user_guess = int(input("Угадайте число от 1 до 100: "))
    if user_guess < secret_number:
        print("Слишком низко!")
    elif user_guess > secret_number:
        print("Слишком высоко!")
    else:
        print("Поздравляем! Вы угадали число!")
        break

Полный код игры

Теперь, когда мы собрали все части, давайте объединим их в один полный код:

import random

secret_number = random.randint(1, 100)

while True:
    user_guess = int(input("Угадайте число от 1 до 100: "))
    if user_guess < secret_number:
        print("Слишком низко!")
    elif user_guess > secret_number:
        print("Слишком высоко!")
    else:
        print("Поздравляем! Вы угадали число!")
        break

Дополнительные улучшения

Теперь, когда у нас есть базовая версия игры, можно подумать о том, как её улучшить. Вот несколько идей:

  • Добавить счетчик попыток: Это поможет игроку видеть, сколько попыток ему понадобилось для угадывания числа.
  • Добавить возможность играть снова: После завершения игры можно предложить игроку сыграть ещё раз.
  • Добавить уровни сложности: Например, можно менять диапазон загаданного числа в зависимости от выбранного уровня.

Пример улучшенной версии

Вот пример, как можно реализовать счетчик попыток и возможность сыграть снова:

import random

def play_game():
    secret_number = random.randint(1, 100)
    attempts = 0

    while True:
        user_guess = int(input("Угадайте число от 1 до 100: "))
        attempts += 1
        if user_guess < secret_number:
            print("Слишком низко!")
        elif user_guess > secret_number:
            print("Слишком высоко!")
        else:
            print(f"Поздравляем! Вы угадали число за {attempts} попыток!")
            break

while True:
    play_game()
    play_again = input("Хотите сыграть снова? (да/нет): ")
    if play_again.lower() != 'да':
        break

Заключение

Создание игры «Угадай число» на Python — это отличный способ попрактиковаться в программировании и освоить основы работы с вводом и выводом данных. Вы можете продолжать улучшать свою игру, добавляя новые функции и возможности. Главное — не бойтесь экспериментировать и пробовать что-то новое!

Примечание

Не забывайте сохранять свой код и делиться им с друзьями!